Increasing connection timeout

Topics: Setup
Apr 27, 2011 at 12:54 AM

Hi,

I'm using URL Rewriter to present Exchange ActiveSync to the Internet from an IIS 6 box in our DMZ.  The problem I'm having is with the 'ping' command used for push based e-mail on the iPhone; I understand that the timeout needs to be at least 15 minutes to work correctly:

2011-04-12T12:04:43 [Proxy] Request: http://xxxxexchange.xxxx.corp/Microsoft-Server-ActiveSync?User=xxxx&DeviceId=Applxxxxxxxxxxx&DeviceType=iPhone&Cmd=Ping
2011-04-12T12:06:07 [Proxy] Error received from http://xxxxexchange.xxxx.corp/Microsoft-Server-ActiveSync?User=xxxx&DeviceId=Applxxxxxxxxxxx&DeviceType=iPhone&Cmd=Ping: The operation has timed out
2011-04-12T12:06:07 [Proxy] No response was received, returning a '400 Bad Request' to the client.

Do you know how I can go about extending this timeout?

The phones work fine and there's no errors on the phone side however the batteries get drained fairly quickly.

Cheers

Coordinator
Apr 29, 2011 at 3:02 AM

Right now there isn't really a configuration option to set the timeout, but you could always compile the source code and add the following to the HttpWebRequest that is going out. 

 

http://msdn.microsoft.com/en-us/library/system.net.httpwebrequest.timeout.aspx

 

I would be interested in hearing your results on this.