Am I missing something? My query strings aren't showing up

Jan 6, 2010 at 1:33 AM

On windows server 2003 x64. 

Here is the output from the log file:

2010-01-05T19:36:23 **********************************************************************************
2010-01-05T19:36:23 [Rewrite] Input: http://beta.ibspartners.com/dataHandler.ashx?smd
2010-01-05T19:36:23 [Rule 0] Input: /dataHandler.ashx
2010-01-05T19:36:23 [Rule 0] Rule Pattern Matched
2010-01-05T19:36:23 [Condition 0] Input: beta.ibspartners.com
2010-01-05T19:36:23 [Condition 0]  Not Matched
2010-01-05T19:36:23 [Rule 1] Input: /dataHandler.ashx
2010-01-05T19:36:23 [Rule 1] Rule Pattern Matched
2010-01-05T19:36:23 [Condition 0] Input: beta.ibspartners.com
2010-01-05T19:36:23 [Condition 0]  Matched
2010-01-05T19:36:23 [Rule 1] Output: http://mysite.com/dataHandler.ashx
2010-01-05T19:36:23 [Rewrite] Proxy: http://mysite.com/dataHandler.ashx
2010-01-05T19:36:23 **********************************************************************************

and the rewrite rule:

RewriteCond %{HTTP_HOST} ^beta [NC]
RewriteRule ^/(.*)$ http://mysite.com/$1 [P,NC,L,QSA]

Does it make a difference that I registered aspnet_isapi.dll from "/Microsoft.Net/Framework64/v2*" instead of from "/Microsoft.Net/Framework/v2*"?

Also, I tried without QSA first...but when it wasn't working and I searched the site here, I saw QSA and thought "Query String Appended?"

 

All help is GREATLY appreciated!

Coordinator
Jan 6, 2010 at 3:01 AM

Try putting your QSA before the L. There may be an issue of order with the flag processing

Jan 6, 2010 at 2:27 PM

Thanks, Nick - that was the right clue.  Turns out QSA must be FIRST in the list (at least in the list I had).

(There is a similar problem with "OR" - I assume someone's working to improve the behavior of the flag processing?)

 

Coordinator
Jan 11, 2010 at 6:49 PM

Can you provide a rule for the problem with the "OR".

Nick

Coordinator
Jan 11, 2010 at 6:50 PM
This discussion has been copied to a work item. Click here to go to the work item and continue the discussion.