Url Reweiter and iJab/JWChat

Feb 20, 2010 at 2:48 PM

I'm trying to port an html page hosted on Apache in a asp.net web application. It has a chat bar from iJab (www.iJab.im) and it use ejabberd as xmpp server.
In apache I use mod rewrite with this configuration

RewriteEngine On
RewriteRule /http-bind/ http://127.0.0.1:5280/http-bind/ [P]

I'm use the same rule in URL Rewriter, but rewrite redirect the call http://localhost:80/http-bind/ to http://localhost:80/http://127.0.0.1:5280/http-bind/ and so I get a server error.

Can you help me? Thanks a lot

Claudio

Feb 24, 2010 at 8:17 PM

Can anybody help me?

Coordinator
Feb 25, 2010 at 3:15 AM

Did you try switching the proxied address to localhost too?

Mar 4, 2010 at 10:27 AM
Edited Mar 4, 2010 at 10:29 AM

Before I used the setting from this documentation, now I try with the web.config in the demo folder and it works!

Probably it miss "engine" attribute of rules section set to Apache in my first webconfig

 

<managedFusion.rewriter xmlns="http://managedfusion.com/xsd/managedFusion/rewriter">
    <rules engine="Apache">
      <apache defaultFileName="ManagedFusion.Rewriter.rules" />
    </rules>
    <rewriter rebaseClientPath="false" allowXRewriteUrlHeader="true" allowIis7TransferRequest="false">
      <proxy useAsyncProxy="true"/>
    </rewriter>
    <!--<rewriter>
	<proxy useAsyncProxy="true" />
   </rewriter>-->
  </managedFusion.rewriter>

Thanks a lot for your ProxyRewrite

 

Coordinator
Mar 4, 2010 at 3:30 PM

Great.

Jul 14, 2010 at 9:42 AM

Hi ClaudioCas,

did you config your iJab on IIS 7 or IIS 6.

I'm get stuck on enabling iJab to work on IIS 7.

Please help me a hand with more details of your steps.

thanks

saosangmo

Sep 17, 2010 at 2:46 AM
ClaudioCas wrote:

Before I used the setting from this documentation, now I try with the web.config in the demo folder and it works!

Probably it miss "engine" attribute of rules section set to Apache in my first webconfig

 

<managedFusion.rewriter xmlns="http://managedfusion.com/xsd/managedFusion/rewriter">
    <rules engine="Apache">
      <apache defaultFileName="ManagedFusion.Rewriter.rules" />
    </rules>
    <rewriter rebaseClientPath="false" allowXRewriteUrlHeader="true" allowIis7TransferRequest="false">
      <proxy useAsyncProxy="true"/>
    </rewriter>
    <!--<rewriter>
	<proxy useAsyncProxy="true" />
   </rewriter>-->
  </managedFusion.rewriter>

Thanks a lot for your ProxyRewrite

 

 

 

What do you have in ManagedFusion.Rewriter.rules file?