Remote_addr

Aug 4, 2009 at 9:43 PM

Hello!

I use ManagedFusion and I am happy. Reverse proxy works as it should be. Outer users can access inner WSGI server.

But attempt to use stats has revealed that HTTP headers of Rewriter Request are rather confusing.

The rewriter adds to Request several headers to the copied original headers

http_x_managedfusion_rewriter_version
:
3.0
http_x_reverse_proxied_by
:
ManagedFusion (rewriter; reverse-proxy; +http://managedfusion.com/)
http_x_rewrite_url
:
/original/path

BUT  remote_addr is ALWAYS refer to local inner server IP address so any statistics lose sense.

When we access the outer server through other web proxy it adds headers

http_via
:
1.1 proxy.r.net:3128 (squid/2.6.STABLE16)
http_x_forwarded_for
:
195.208.203.111

These headers allow to restore original client IP.

 

But ManagedFusion does not allow to restore original IP 

Please, describe any methods to overcome such behavior.

I tried flag [E=HTTP_X_REMOTE_ADDR:%{REMOTE_ADDR}] in RewriteRule clause but it failed

 

As to me, traverse of original addresses are much more better, they support full transparency.

If this behavior is an issue, then fix it please.

 

Dmitry Sherbina

 

 

 

 

 

 

 

 

Coordinator
Aug 5, 2009 at 12:23 AM
This discussion has been copied to a work item. Click here to go to the work item and continue the discussion.
Coordinator
Aug 5, 2009 at 1:27 AM

Hi Dimitry,

Didn't even know those headers were in existance.  Thanks for pointing them out to me.  Please check the work item for a download and let me know if that solves your issues.